User Tools

Site Tools


oe_yp_migration

This is an old revision of the document!


Overview

Migration issues in various releases.

Yocto Project 2.3 (morty -> pyro)

  • recipe-specific sysroots, so you must be more rigorous about DEPENDS – those dependencies will be populated into the recipe's sysroot
  • PACKAGE_WRITE_DEPS to enumerate host tools necessary for pre- and post-install scripts; see “Post-Installation Scripts” in Dev Tasks Manual (see do_rootfs() task)
    PACKAGE_WRITE_DEPS += "${@bb.utils.contains('DISTRO_FEATURES','systemd sysvinit','systemd-systemctl-native','',d)}"
  • SYSROOT_PREPROCESS_FUNCS
  • Check per-recipe settings of SYSTEMD_AUTO_ENABLE
    recipes-bsp/apmd/apmd_3.2.2-15.bb:SYSTEMD_AUTO_ENABLE = "disable"
    recipes-connectivity/dhcp/dhcp.inc:SYSTEMD_AUTO_ENABLE_${PN}-server = "disable"
    recipes-connectivity/dhcp/dhcp.inc:SYSTEMD_AUTO_ENABLE_${PN}-relay = "disable"
    recipes-connectivity/dhcp/dhcp.inc:SYSTEMD_AUTO_ENABLE_${PN}-client = "disable"
    recipes-connectivity/wpa-supplicant/wpa-supplicant_2.6.bb:SYSTEMD_AUTO_ENABLE = "disable"
    recipes-core/util-linux/util-linux.inc:SYSTEMD_AUTO_ENABLE_${PN}-uuidd = "disable"
    recipes-core/util-linux/util-linux.inc:SYSTEMD_AUTO_ENABLE_${PN}-fstrim = "disable"
    recipes-devtools/dnf/dnf_2.7.5.bb:SYSTEMD_AUTO_ENABLE ?= "disable"
    recipes-extended/mdadm/mdadm_4.0.bb:SYSTEMD_AUTO_ENABLE = "disable"
    recipes-extended/watchdog/watchdog_5.15.bb:SYSTEMD_AUTO_ENABLE = "disable"
    recipes-extended/sysstat/sysstat.inc:SYSTEMD_AUTO_ENABLE = "enable"
    recipes-extended/sysklogd/sysklogd.inc:SYSTEMD_AUTO_ENABLE = "enable"
    recipes-kernel/lttng/lttng-tools_2.9.11.bb:SYSTEMD_AUTO_ENABLE = "disable"
  • Per-recipe STAGING_DIR_NATIVE
  • lnr (poky/scripts/lnr); relative_symlinks.bbclass
    do_install[postfuncs] += "install_relative_symlinks"
    
    python install_relative_symlinks () {
        oe.path.replace_absolute_symlinks(d.getVar('D'), d)
    }
  • Smart package manager replaced by DNF
    • Smart no longer maintained
    • Smart not ported to Python 3
  • RPM 5 downgraded to RPM 4
    • DNF incompatible with RPM 5
    • RPM 5 just not popular

Yocto Project 2.4 (pyro -> rocko)

  • no need to include linux-dtb.inc anymore

Yocto Project 2.5 (rocko -> sumo)

Yocto Project 2.6 (sumo -> thud)

oe_yp_migration.1582543230.txt.gz · Last modified: 2020/02/24 11:20 by rpjday